BMW Connected app and TFT display

Discussion in 'Mapping & Navigation' started by Trickle007, May 20, 2020.

  1. Trickle007

    Trickle007 Adventurer

    Joined:
    May 7, 2020
    Oddometer:
    21
    Location:
    PA
    Anyone use the bmw Connected app from phone and sinc it to your TFT display on your BMW? I can't seem to get it to work . I connect my my phone to my bike and the enter a destination on my phone then click go. The TFT display then shows the a flag and under that it says start. But I cant get it to start. Even when I I start driving nothing changes on the display it just says start any help would be appreciated. Thanks
    #1
  2. Fosters

    Fosters Loner

    Joined:
    Nov 6, 2010
    Oddometer:
    424
    Location:
    florida
    Have you checked permissions in settings on your phone?
    #2
  3. DRTBYK

    DRTBYK All Things GPS Supporter

    Joined:
    Mar 26, 2003
    Oddometer:
    8,155
    Location:
    48°58′18.9″N, 89°57′39.1″E
    #3
  4. seezur

    seezur Adventurer

    Joined:
    Aug 29, 2019
    Oddometer:
    24
    Location:
    NY
    That video is extremely basic and I don’t think will be much use to OP.

    I’ve been using the Connected app since last summer. It has always been spotty in terms of connecting and navigating, but worked maybe 80% of the time. This season it is essentially unusable for me as the directions the app will give audibly (which are correct) and the directions shown on the TFT are completely different. It’s as if the TFT is delayed or gets stuck. Likewise the speed limit data will freeze and won’t change and the bike will not allow me to cancel the route via wonder wheel. The Connected app now works for me less than 10% of the time.

    I’m not sure what phone you use, but I “upgraded” from an iPhone 8 to an 11 Pro. Somewhere during that upgrade I also updated to iOS 13. In iOS 13 Apple made attempts to make location services more transparent. I now get prompts periodically for the Connected app (and others) asking if I want to continue to allow it to use my location always (which I do, as this is a prerequisite for the app and it’s navigation feature to work). Despite changing permission to “always”, I still get prompted to always allow.

    I can’t be sure but since this is the only thing that has changed other than a winter 6k service I’m wondering if the iPhone is intermittently disconnecting the Connected app from location services and causing issues displaying to the TFT. If any of this applies to you, maybe this is the problem you’re having. Unfortunately this is likely not fixable as the problem is built into iOS 13.
    #4
  5. Trickle007

    Trickle007 Adventurer

    Joined:
    May 7, 2020
    Oddometer:
    21
    Location:
    PA
    I have a Galaxy Note 9. The app worked 1 time and now any time I try to use it the TFT just display the word start and a flag. I never get it to passed that point. I am going to uninstall and reinstall
    #5