BMW G650X Challenge Thread Index

Discussion in 'Thumpers' started by GB, Apr 24, 2008.

  1. milosbgd

    milosbgd X

    Joined:
    Apr 11, 2011
    Oddometer:
    60
    Location:
    Belgrade, Serbia
    Please, could some body help me, my fuel pump died after 12.000 Km and the price for new is totaly crazy expencive, it cost 300 Eur!!
    Does some one knows is there any replacement, thoes it fit from other Bike manufactures, from some car, etc...


    Please help!
  2. milosbgd

    milosbgd X

    Joined:
    Apr 11, 2011
    Oddometer:
    60
    Location:
    Belgrade, Serbia
    Please could some body can help me, I have Fuel Pump problem on my G650XC, it stops after 12.000 Km and the price in BMW for new pump is 300 Eur, crazy expencive!!!!
    Does some one knows is ther some replacement, from other bikes, cars, etc....

    Please help me!!!

    Thank you
  3. werner747

    werner747 Adventurer

    Joined:
    Mar 4, 2009
    Oddometer:
    35
    Ive been told these items are the same as the BMW fuel pump:

    BOSCH part #: 0 580 453 465
    VDO part #: 993 784 025 A

    Havent tried to fit replacement yet, but carry the VDO as spare. In South Africa the VDO costs about R300 = +/-$43 = +/-30 Euro.

    Should be available at most motor spares shops, just take yours with and match it up at the shop.
    Hope it helps.
  4. Rose

    Rose Been here awhile

    Joined:
    Apr 30, 2006
    Oddometer:
    151
    Location:
    Schriek, Belgium
    I thought perhaps a bend gear shaft would interfere with the transmission as well, but looking at the pictures I don´t know why I thought that actually :shog
    I think I misunderstood all the stuff that´s going on with my friends engine.
  5. FinnDuro

    FinnDuro Winter wonderlanding

    Joined:
    Aug 15, 2007
    Oddometer:
    460
    Location:
    Finland
    Are you sure it really is the fuel pump that died? How did you come to that conclusion, if I may ask? Reason for asking this is: early G650X bikes have a known weak point inside the fuel pump housing, the wiring connectors in there may fail, leading to malfunctioning fuel pump. Maybe you simply have this connector issue, but then you will not know unless you open up the fuel pump housing....?
  6. milosbgd

    milosbgd X

    Joined:
    Apr 11, 2011
    Oddometer:
    60
    Location:
    Belgrade, Serbia
    Thank u very much for your information, I will try tomorrow and let you know!

    b.r
    Milos
  7. Colebatch

    Colebatch "Moto Porn"ographer

    Joined:
    Jul 7, 2006
    Oddometer:
    4,229
    Location:
    Schmocation
    14 is not original! ... 15 is.

    14 x 8 = 112 , exact multiple ... i.e everytime your chain goes around, it matches up with exactly the same front sprocket teeth, every time.

    Dunno if its related, but exact multiples are a huge contributor to uneven chain and sprocket wear.
  8. dirtsurfer

    dirtsurfer Adventourer

    Joined:
    May 10, 2006
    Oddometer:
    4,561
    Location:
    In the garage
    I have good used complete fuel pump assembly I will sell you cheap. But first, how do you know that your fuel pump is broken?
    I ask this question because I dont want you to make the same mistake that I did. I replaced my fuel pump when it kept blowing fuses. I replaced the fuel pump to find that it shares a fuse with the fan which was faulty
  9. Rev Kiecker

    Rev Kiecker Been here awhile

    Joined:
    Sep 2, 2002
    Oddometer:
    729
    Location:
    Tulsa, OK
    Why times 8?
  10. Colebatch

    Colebatch "Moto Porn"ographer

    Joined:
    Jul 7, 2006
    Oddometer:
    4,229
    Location:
    Schmocation
    the 8 part is not relevant ... point is, if you have an exact multiple, the same part of the chain will hit the same tooth on the sprocket every rotation of the chain. If you have a damaged link , or a stiff link or whatever issue with one link or segment of of the chain, it will only ever affect one tooth, as it will be hitting the same one every time ... ergo uneven chain and sprocket wear.
  11. Rev Kiecker

    Rev Kiecker Been here awhile

    Joined:
    Sep 2, 2002
    Oddometer:
    729
    Location:
    Tulsa, OK
    It's late here....makes perfect sense. I was over thinking regarding tooth/diameter size, but that's completely unnecessary if you also know quanity of links used. Duh!
  12. Tomdog

    Tomdog Mapaholic

    Joined:
    Sep 17, 2008
    Oddometer:
    666
    Location:
    Kiwi on the Gold Coast. Australia
    OK this is the scenario thats driving me nuts.
    Starts cold without hesitation (90% of the time). Occasionally a weak fire then stop, hit the starter again and fuse "F" blows. Change fuse then all is good for a start.
    Run the bike for half an hour or more, stop, ignition on, hit starter, blow fuse "F" multiple times before starting.
    Initially symptoms started (fuse blowing occasionally when hot) a few months ago until now where it will blow fuse F (on start up) every time engine is hot.
    Actions to date;
    A/ New Yuasa battery.
    B/ All connections to battery, ground, starter solenoid, starter inspected and cleaned.
    C/ Starter solenoid and starter switch swapped out from mates X-C
    D/ Head light isolator switch installed so light can be off when starting.

    According to my manual, fuse "F" services Starter Relay, Flashing Turn Indicators, Diagnosis plug. Instrument cluster must be in there too because it definitely goes dead with the fuse blown.

    Any thoughts on this issue would be much appreciated. :evil
  13. LangKat

    LangKat Adventurer

    Joined:
    Jul 22, 2011
    Oddometer:
    68
    Location:
    Johannesburg
    Has anybody had a problem with their fuel pump failing after installing an aux tank?

    Some other BMW owners (X-C and F800) have said that 6000km after installing their aux tanks their fuel pumps died. They connected the outlet from the aux tank to the breather on the main tank. They reckon it is because the aux tank places more load on the pump. I disagree with this theory but I'm not the one who's fuel pump died.

    Any known issues in this area?
  14. Butters

    Butters Kwyjibo Supporter

    Joined:
    Oct 10, 2008
    Oddometer:
    7,826
    Location:
    NoVA
    I haven't heard about it on XChallenges, but other BMWs (as well as other bikes) seem to have faulty starter relays. It doesn't look like you tried checking that yet.
  15. milosbgd

    milosbgd X

    Joined:
    Apr 11, 2011
    Oddometer:
    60
    Location:
    Belgrade, Serbia
    Ohh
    first thank u for the Bosch number, i bought it and it fits the bike (80eur) !!! BUT....in the service they change the pump and still dont working, some times works some time not!!!,,
    it could be the same problem with your bike.....i will tell them to check the fuse box(btw. its the BMW service!) for shure problem is in electricity...
    Thanks
  16. Tomdog

    Tomdog Mapaholic

    Joined:
    Sep 17, 2008
    Oddometer:
    666
    Location:
    Kiwi on the Gold Coast. Australia
    Thanks Butters, I have swapped starter relays with another XC with the same results.
  17. aprilian

    aprilian Can I change this?

    Joined:
    Feb 20, 2009
    Oddometer:
    478
    Location:
    MinneSNOWta
    long shot here.

    I felt something hit my foot yesterday when riding my Xmoto. A quick mental inventory of my possesions had me concluding that it was a rock or bolt thrown up by the front tire. Later, I looked at the bike and realized it was the front header heat shield. I went back and could not find it :cry

    Anyone got a spare to sell?
  18. DESERT SCORPION

    DESERT SCORPION SINGLE TRACK

    Joined:
    Jul 24, 2008
    Oddometer:
    210
    Location:
    SINGLE TRACK IN THE WOODS
    PM sent on available shield.

    The Scorpion
  19. dakardad

    dakardad Not waiting for anyone

    Joined:
    May 22, 2006
    Oddometer:
    447
    Location:
    SLC/Boulder, Ut.
    Sorry to but in here but, Ive been looking for that set of posts that cover front fork replacements. Posts from HP2, colebatch and others. had pics of top tubes that had been turned down to fit stock triple clamps.
    Anyone know where that set of posts are?:ear
  20. Tomdog

    Tomdog Mapaholic

    Joined:
    Sep 17, 2008
    Oddometer:
    666
    Location:
    Kiwi on the Gold Coast. Australia
    In here somewhere? "BMW G650XChallenge Front Suspension" http://www.advrider.com/forums/showthread.php?t=277533