BMW GS/GSA TFT Megathread

Discussion in 'GS Boxers' started by Matrixmatt, Aug 21, 2018.

  1. Mr Magnum

    Mr Magnum Adventurer

    Joined:
    Aug 22, 2019
    Oddometer:
    26
    Location:
    Annecy, France
    Like I said, I got a minor TFT update last Tuesday and I must say that it finally works. Last night I even reconnected the Nav6 to my phone, no skipping either !
    mikegc likes this.
  2. BlackPaw80

    BlackPaw80 Adventurer

    Joined:
    Apr 5, 2013
    Oddometer:
    47
    Location:
    Denver, Colorado
    Updating some of my previous posts here I may have found something that works for the Bluetooth issues. First I followed this guys video, exactly, step by step:

    FYI: I have to have Apple Music, Smart Link, and the BMW Conncted apps open on my phone prior to powering on for the below to work.

    After the video steps it all worked really well but I still found that it skipped sometime so I tried muting the Nav6, that seemed to stop the skipping of music. Maybe the Nav6 and TFT are still competing too much for the Sena 20 evo, even with the Nav only connected as an intercom, who knows.

    I also switched to Apple Music instead of Spotify and now I can access and change my playlists, artists, etc.. form the wonder wheel on the TFT or the Nav6.

    FYI if I do the connections any other way than what this guy has stated in his video I have all kinds of problems.
  3. Mr Magnum

    Mr Magnum Adventurer

    Joined:
    Aug 22, 2019
    Oddometer:
    26
    Location:
    Annecy, France
    Would you care detailing your steps precisely ?
  4. BlackPaw80

    BlackPaw80 Adventurer

    Joined:
    Apr 5, 2013
    Oddometer:
    47
    Location:
    Denver, Colorado
    You know I’m actually going to write down the steps from the video for myself so I can redo it if I ever have problems and I won’t have to watch the video out on the road. When I do I’ll repost it here. In a nutshell you delete ever connection from the bike, Nav, your phone, and your headset. You update them all to the latest software/firmware versions. Then connect in a specific order. He did mention that some older headsets with a lower Bluetooth technology will not work very well. I’m running the 20S EVO and it seems to be fine.
  5. Mr Magnum

    Mr Magnum Adventurer

    Joined:
    Aug 22, 2019
    Oddometer:
    26
    Location:
    Annecy, France
    Well, thanks awfully, have a beer or 5 from me.
  6. SidewinderX

    SidewinderX Hey, watch this! Super Supporter

    Joined:
    Nov 3, 2009
    Oddometer:
    2,251
    Location:
    NW North Carolina
    This but you really need to watch his entire detailed explanation to gain the best outcome.

    For instance, you need to delete the TFT pairings then do a 1 min shutdown so it will properly reset.

    C2866DB7-A643-486D-9971-06CC293270FC.jpeg
  7. Mr Magnum

    Mr Magnum Adventurer

    Joined:
    Aug 22, 2019
    Oddometer:
    26
    Location:
    Annecy, France
    I'll watch it tomorrow !
  8. BlackPaw80

    BlackPaw80 Adventurer

    Joined:
    Apr 5, 2013
    Oddometer:
    47
    Location:
    Denver, Colorado
    Okay Magnum here you go, this is how I do it and it works with the following setup; 2019 1250 GSA TFT, BMW Navigator VI, Sena 20S EVO, iPhone X.

    1. Update EVERYTHING (firmware/software); bike, nav, phone, headset, apps on phone.

    2. RESET ALL CONNECTIONS

      1. iPhone: >settings >bluetooth >tap on connection >forget device (ICC6.5 and NAV)
      2. SENA: >turn on >hold phone button 10 seconds >says “factory reset” >tap jog dial,
      says “goodbye” and turns off
      3. NAV: >settings >bluetooth >select device >unpair device 4. TFT: >settings >connections >delete all connections

    3. PAIRING ORDER (the exact order you do this matters)
      1. Sena to TFT
        1. TFT >settings >connections >riders helmet
        2. push and hold phone buttons on Sena, will say “phone pairing” 3. TFT >rider helmet >pair new rider helmet >select your headset

      2. Navigator to Sena
        1. Navigator >settings >open bluetooth
        2. Sena >push and hold jog dial, will say “intercom pairing”, release jog dial
        and tap phone button, will say “second phone pairing”
        3. Navigator >scan for devices >choose Sena >hit ok and pair >click the
        checkboxes for pair media and headset

      3. Pair phone to TFT
        1. Open bluetooth connections on your phone
        2. On the TFT select: >mobile device >pair mobile device >pair and confirm
        >allow contacts to sync

      4. Pair phone to Navigator
        1. Open bluetooth on navigator settings
        2. click scan for devices on Navigator
        3. pair to phone
        4. DON'T allow contacts to sync
        5. Now on the Navigator click on your phone
        >>> unselect the box that says ‘phone calls’ 2. select the box that says ‘smartphone link’ 3. select the box that says ‘media’
    German, VCheng, Two Tigers and 3 others like this.
  9. Mr Magnum

    Mr Magnum Adventurer

    Joined:
    Aug 22, 2019
    Oddometer:
    26
    Location:
    Annecy, France
    I've sent a keg of the finest beer your way. I'm going to try that tonight !
  10. Mr Magnum

    Mr Magnum Adventurer

    Joined:
    Aug 22, 2019
    Oddometer:
    26
    Location:
    Annecy, France
    Ok, so I tried this very combination however, even when I connect the Packtalk to the Navi6 as a GPS, it gets dropped once the TFT connects to it, and once the TFT is on, there's nothing that can be done to the PackTalk. Man, this is so frustrating and so stupid.
  11. BlackPaw80

    BlackPaw80 Adventurer

    Joined:
    Apr 5, 2013
    Oddometer:
    47
    Location:
    Denver, Colorado
    I’m not too familiar with the Packtalk. How old is it? In the video he mentions older bluetooth devices are almost impossible to get to work perfectly.
  12. Mr Magnum

    Mr Magnum Adventurer

    Joined:
    Aug 22, 2019
    Oddometer:
    26
    Location:
    Annecy, France
    My bad. I made a mistake. I didn't click twice on the phone key to pair as GPS, I was pairing it as a phone.
    It's actually brand new, latest iteration from Cardo with JBL Sound. Sound quality is phenomenal is it has the ability to create a real time network between many riders equipped with the same equipment.
  13. Mr Magnum

    Mr Magnum Adventurer

    Joined:
    Aug 22, 2019
    Oddometer:
    26
    Location:
    Annecy, France
    So I paired it as a GPS, and unchecked Phone on the Navi6. I have the GPS totally muted as I don't like the constant chatter.
  14. bikeroz

    bikeroz Long timer

    Joined:
    Oct 18, 2012
    Oddometer:
    2,084
    Location:
    Sydney Lower North Shore
    I interpret that as your packtalk only has one channel for 'phone' unlike the Sena that has 2 channels to use for phone, one from Nav and one from TFT.
  15. Mr Magnum

    Mr Magnum Adventurer

    Joined:
    Aug 22, 2019
    Oddometer:
    26
    Location:
    Annecy, France
    I actually has 2 channels for phones... About to go to the beach, short ride but still will validate the config in 20 minutes :)
  16. Fastman

    Fastman Been here awhile

    Joined:
    Sep 15, 2002
    Oddometer:
    615
    Location:
    Webster Groves, MO
    The Packtalk Bold has 2 channels. The TFT gets paired to "phone 1" and the Nav VI should be paired (as a GPS) to the 2nd phone channel.
  17. Candubrain

    Candubrain Been here awhile

    Joined:
    Jan 13, 2018
    Oddometer:
    408
    Location:
    Kincardine, ON, Canada
    I've had my TFT drop both my XR iPhone and my Headsets twice in the last 2 weeks. I had to go through the pairing process for both each time as if it was the first time.

    presently I have firmware version 001_019_180

    Is this the latest and greatest version?

    Going in for my 20Kms service on tuesday.
    thanks
    brian
  18. NoiZboy

    NoiZboy Dirt to Track and Back Again

    Joined:
    Dec 24, 2012
    Oddometer:
    454
    Location:
    Northern, VA
    Yes, that's the current version - I just got mine back from the shop yesterday (Aug. 31) and 001-019-180 is the version they installed. So far it's been solid since I got it back.

    UPDATE: I apparently spoke to soon. While the setup worked ok for a few days, it started acting up again during regular weekday commuting. Same problems as before - inconsistent/frequently dropping connections, playback issues like skips, speeding up/slowing down, etc. For whatever reason, the TFT just doesn't seem to work with my setup, so I've decided to move to using the Nav VI as my BT hub and to have no connection at all to the TFT. So far that's been much better than the TFT ever was. See more info in my post further below (#311).
    Candubrain likes this.
  19. Candubrain

    Candubrain Been here awhile

    Joined:
    Jan 13, 2018
    Oddometer:
    408
    Location:
    Kincardine, ON, Canada

    Not that I'm aware of.
    My update was done April 2019; I have no NAV, just the same iPhone and Uclear Amp Plus headset that I had last year. It was stable and fine until now.
    There does not appear to be any fighting going on. One day its fine, the next day I've lost pairings on the TFT. When you look under the bluetooth tab on the iPhone the TFT is still showing in the list, but the TFT's list of pairings is empty.

    Perhaps the TFT just needs a refresh.
  20. NoiZboy

    NoiZboy Dirt to Track and Back Again

    Joined:
    Dec 24, 2012
    Oddometer:
    454
    Location:
    Northern, VA
    Just a thought, but have any iOS updates been run? 12.4.1 came out not too long ago. An iOS update a while back upset some other BT connections I have (Fitbit, my car's BT). I fixed the car's by just wiping out the connection at both ends and resetting, but to fix the Fitbit I had to do a full reset & clean install on the phone. So many variations and possibilities ...
    Candubrain likes this.