BMW Navigator VI and Media Player- Garmin Response Jun 12, 2017

Discussion in 'Mapping & Navigation' started by Dakarider, Jun 12, 2017.

  1. scfrank

    scfrank Old farts riding club. Supporter

    Joined:
    Oct 27, 2005
    Oddometer:
    25,461
    Location:
    Upstate SC
    Just had interesting experience with my Nav VI and music. As I stated somewhere above, I had the media player working with my iphone, but recently tried to use it again and the controls, play, pause, etc didn’t work. I had done a reset on my Nav for other reasons so I figure that caused it to stop working. To be fair, the iPhone has had an update also. I went back through all the pairing stuff as before and still no go. I have the Sena 30K and iPhone. So, I thought, why not try to get some mp3 music on the Nav SD card and see how that works. Well, after a few hours figuring out how to convert a few mp3 songs and out of iTunes and onto the SD card, that worked as expected. Guess what, now the controls work on the iPhone setting also. At least until the next update.
    #61
  2. ADVwxyz

    ADVwxyz yep Super Supporter

    Joined:
    Aug 11, 2015
    Oddometer:
    612
    Location:
    vancouver
    Yea -same-... sometimes fine sometimes not
    #62
  3. dj_00

    dj_00 GunkL

    Joined:
    Jun 21, 2009
    Oddometer:
    24
    Location:
    Santa Clara, CA
    The above worked for me, sorta!

    So here's where I'm currently at- I'm going to provide an exact list as possible, since I see a lot of mixed data in the thread, but there's a lack of clarity of which sena, phone, nav, etc in most posts.

    Hardware:
    Sena SC1S v1.0 (v1.1 has a stupid lower volume update, looks like i can't use it)
    BMW NAV VI on latest firmware as of May 16 - I saw an update yesterday morning and applied it
    Iphone 8 - Latest IOS 11.3.1

    First attempt worked; I don't know exactly what I did, but I believe my Sena was paired to my phone already, then I paired my phone to the Nav VI, and then paired my Sena to the Nav VI, probably with "Secondary phone pairing".
    I had the same results by following scfrank's instructions above after unpairing everything and factory resetting my Nav VI.
    What worked:
    Navigation / voice
    Phone calls (using the nav screen to dial)
    Volume control (on the SC1 itself, not wonderwheel)
    Music browse, forward/backward/pause.

    Doesn't work:
    Siri (press voice dial on NAV, I get a "speak now screen") - I can see on my phone Siri is activated, but there's no audio connected to/from Siri at this point - so siri can't hear me. no audio beep or nothing.


    I then tried to make Siri work, and I tried every different combination of what I've found here, I think I've burned at least 4-5 hours now on this, and wound up returning to this same process. A few things I learned along the way:
    1) If the NAV VI goes into a weird state where when you try to pair you just get the hourglass forever, and then it finally says bluetooth connection failed (or on your phone) there's really only one solution at this point, Factory reset the Nav VI - this means remove it from the mount, press the physical power button until the power off button comes up, then put your finger in the bottom right of the screen, hold it there while pressing power until the screen lights up (no backlight at this point) and says "SYSTEM" across the top. Then start over.

    2) Always "unpair" everything before trying any new attempts, unpair from the NAV VI, delete all pairings from the sena, and "forget all devices" from your phone.

    3) I've gotten into cases where the media player controls don't work (fwd/back/pause) and I've found that this usually solves itself. I haven't figured it out 100% yet, but I have two theories:
    a) The phone is busy syncing contacts and crap to the NAV, and the media controls are just not making it.. wait a bit, it resolves itself
    b) Reboot either the NAV or the phone seems to resolve it.


    I wish Siri would work. Since I can dial by phone book it's really not a big deal, but Siri was generally very convenient for playing apple music / switching music easily more than anything else. The media player doesn't seem to have a way to play podcasts or apple music which is a bummer to lose, seems like I can play them as long as I pull my phone out and start them there.
    #63
    ADVwxyz likes this.
  4. ADVwxyz

    ADVwxyz yep Super Supporter

    Joined:
    Aug 11, 2015
    Oddometer:
    612
    Location:
    vancouver
    Yea- pretty much same here... thx for the detail!
    #64
  5. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    9,375
    Location:
    alabama

    this crazy sequence of events is proof of how terribly poor the implementation of Bluetooth is in this device.

    for comparison....

    I just watched a non smartphone user pair a phone to a car radio, play music, and make calls. it took literally ten seconds. no on/off/on/off/tap-the-brake-pedal-three-times kind of silliness, no factory resetting, no pair-it-exactly-this-way-or-your-have-to-reboot-everything-factory-reset-and-start-over-crap.... none of the that silliness.

    just
    turn on car/radio
    turn on phone booth
    car radio asked to pair, press yes
    end of pairing sequences


    playing music and phone calls were simply seemless and painless after that.

    it took longer to start the car and about the volume than to pair n play.


    y'all really need to be burning up the gaming help center phone lines of you ever expect it to get anywhere near what it should be
    #65
  6. scfrank

    scfrank Old farts riding club. Supporter

    Joined:
    Oct 27, 2005
    Oddometer:
    25,461
    Location:
    Upstate SC
    I agree with you. But, there is a significant difference between your example and the Garmin/iPhone/Sena situation. One less device. But, I would agree, Garmin seems many years behind the curve on software.
    #66
  7. elcabong

    elcabong Been here awhile

    Joined:
    Jun 21, 2015
    Oddometer:
    689
    Location:
    So.Cal.
    Been reading this entire thread and I'm about to explode. A little context. My riding buddy bought a new helmet and of course, it had to come with a Sena on his C4. Prior to that he had a C3 pro and utilized the SRC comm unit (made my Cardo). I used a Cardo Scala Q3 and it worked flawlessly on my 12GSW, NAV VI and iPhone 6S. Since the Q3 is a few years old I got a good deal on the Sena 20S EVO. Connectivity for GPS, phone calls, radio - all works as it should. What's killing me is trying to get the media player (using MP3) to fwd/back/pause via the jog dial and it's seems to be flakey. I thought I got it. Everything worked - so happy. Then I installed it on the bike and one of the connections momentarily dropped off (NAV to Sena) and reconnected and now it doesn't work. FAAK! :beccaI've reset, paired and unpaired so many different ways (your suggestions, the Manual, blogs) and the outcome is never the same. It works, then it doesn't. How can that be? I need another day to figure this out or it's going back to the dealer and I'd rather not talk to my buddy anyway.
    #67
  8. scfrank

    scfrank Old farts riding club. Supporter

    Joined:
    Oct 27, 2005
    Oddometer:
    25,461
    Location:
    Upstate SC
    ^^^^. Unfortunately, sounds familiar.

    I’m getting ready to mount my phone to my bars and not pair my gps. I can press the home button and use Siri to control iPhone. That’s the plan. I have Sena 30K. Don’t like all the gps interruptions anyway. I can just look at it, right?

    It seems clear that Garmin hasn’t done much testing with Nav vi and Sena iPhone combo.
    #68
    ADVwxyz likes this.
  9. zmw

    zmw Adventurer

    Joined:
    Jul 1, 2018
    Oddometer:
    11
    Location:
    satx
    you can further complicate it by buying a 2018+ with the TFT and computer pro - I pair my phone with my bike, I pair my headset with my bike, that allows me to control my phone and media through the TFT and jog wheel on the GSA, I do not do any pairing with the garmin at all - this is definitely a half baked solution - BMW needs to build garmin into the TFT natively or make a solution that doesn't suck so badly. I mean every 250$ double din head unit for a car has a better experience than we are getting for thousands of dollars.
    #69
  10. scfrank

    scfrank Old farts riding club. Supporter

    Joined:
    Oct 27, 2005
    Oddometer:
    25,461
    Location:
    Upstate SC
    This is the sad part. The knowledge and expertise is available to make this stuff functional. It just doesn’t get applied. I think BMW Motorrad just doesn’t see it.

    I’m looking at a new pickup truck at the moment. They all have screens that pair with your phone, have gps available, XM, weather, etc. I’m betting they are easier to use and have reliable functionality.
    #70
  11. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    9,375
    Location:
    alabama

    uhm.... your going to want to USE one of those before you believe in it. what they look like in the sales brochure vs how perform, are vast differences
    #71
  12. scfrank

    scfrank Old farts riding club. Supporter

    Joined:
    Oct 27, 2005
    Oddometer:
    25,461
    Location:
    Upstate SC
    I’ll file a report. But, you might be right. Supposedly I can send a route from my phone to the truck. Not sure why I would. I’m learning to just use my phone. Sound familiar?
    #72
  13. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    9,375
    Location:
    alabama

    yuppers. I'm just hoping they've made huge improvements over the last five years to car nav units. the user input dialogues are so cluttered and ass backwards it seems like they're trying to impress people with complications instead of good interfaces.... "it's hard to use, it must be my fault" kind of stuff.

    do log a report, I'm sure a lot of folks can benefit from your opinion! :-)
    #73
  14. texas123

    texas123 Been here awhile

    Joined:
    Jul 8, 2018
    Oddometer:
    180
    Location:
    Houston suburbs
    New to the forum and technology; however I do have a question if someone could help me out?
    Is there a reason to connect my Apple 5 telephone to the Nav 6 if I don't intend on using wireless speakers in my helmet? They connected via Bluetooth, but I'm not sure what the advantage would be.
    #74
  15. andynj

    andynj Been here awhile

    Joined:
    Jul 9, 2013
    Oddometer:
    412
    Have the same issue, can't get the buttons and jog wheel to control the media player consistently have also tried all kinds of resets and different connections usually works after I mess with it for a few hours then just stops working. No consistent thing makes it start or stop working. Its really annoying, I spoke to Garmin and they said I could RMA the unit but I don't want to send it off for 2 weeks and find the same issue with a new unit. I think its a software bug, my guess is that the garmin is connecting via bluetooth connection not iphone connection (event though its set to iphone) as it plays music and displays it fine but the buttons just dont work.
    #75
  16. sb955i

    sb955i Grudge no toil.

    Joined:
    Feb 7, 2008
    Oddometer:
    250
    Location:
    Caledon, Ontario
    Only thing to consider is if you will be using the Garmin Smart Link app which is hosted on your iPhone and renders on the NAV 6.

    Smart Link provides onscreen weather maps, and live traffic. It also has Foursquare which I don't use, traffic cameras ( called Photo Live) Some of these require a small in-app purchase one-time price. Weather maps can be useful, but they're not accessible from the jog-wheel.. requiring a tap on the app-screen of the NAV. Keep in mind the app will use data, but not much.
    #76
  17. mxz

    mxz Been here awhile

    Joined:
    Sep 11, 2015
    Oddometer:
    733
    1,5 years in and the Nav VI is still crap. Bought a Zumo 390 to use on other bikes and everything there just works out of the box. Media controls and all.


    Sent from my iPhone using Tapatalk
    #77
  18. vinnyl26

    vinnyl26 Been here awhile

    Joined:
    Dec 2, 2008
    Oddometer:
    145
    Location:
    San Jose, CA
    So something I’ve found interesting. I had the nav 6 for a year. Never could get the whole iPhone Sena pairing so that the media player and phone work as designed. It was a total headache. So I sold my bmw and bought a Garmin 595 to go with my new bike. That thing works flawless as it should. Media player over Bluetooth works perfect. Answers and dials phone. Why the hell cant Garmin get it right with the Nav 6?
    #78
  19. Miatatat

    Miatatat n00b

    Joined:
    Feb 7, 2018
    Oddometer:
    5
    Location:
    Nashville, TN
    I’ve got the iPhone X, the Nav VI, and a Sena SMH10R. Software on all devices up to date with this posting. I read through all of this forum, and the issue I was having was I could either set it up to send and receive phone calls OR stream my media from my phone. The fix that got everything working as it should was to pair the NAV and Sena with “phone pairing” because that connection type uses both A2DP and HFP. Here are the instructions:

    Clear all devices of all previous pairings

    Factory reset Sena

    Pair Sena with Nav VI using PHONE PAIRING from the configurations menu.

    Pair phone with Nav VI
    #79
    elcabong likes this.
  20. rock sniffer

    rock sniffer n00b

    Joined:
    Apr 15, 2019
    Oddometer:
    3
    Location:
    Tx
    I tried this and it worked to control pause/play/skip etc on the iPhone iTunes from the Nav VI.

    Let me add, I have a 20s too and media app also functions . For both I removed, forgot or unpaired all from the phone, headset and nav, turned each off and on except the phone. On the 10r I followed the directions above. For the 20s I paired the headset to the Nav VI then the phone to the Nav VI. I left everything on and paired up for about 10 min (not that it made any difference but it does copy contacts to nav). Was done off the bike

    So I had two headsets working separately. Next day when I turned them on both worked but stopped while I was playing with them (off and on). Repairing, turning off and on, generally screwing with it got the 10r working. I think what screwed it up was jumping to the media app before the phone finish pairing. The Nav is slow. The phone will take 30 -60 seconds to pair up.

    It’s a shame two years later the media app is still quirky. I paid the same for my iPhone X and it’s light years ahead in speed and functionality.
    #80