Computer never recognizes BMW NAV VI

Discussion in 'GPS 101 - Which GPS For Me' started by Gadgetech, Jun 11, 2019.

  1. Gadgetech

    Gadgetech Been here awhile Supporter

    Joined:
    Aug 6, 2017
    Oddometer:
    556
    Location:
    Cumming, GA
    Hello, I'm reaching out in hopes someone can help me troubleshoot this issue I have. I have a Surface Book running Windows 10 Pro with the 1903 update (recently updated) and this particular machine will NEVER recognize the GPS without me going into the device manager (even when it was on the 1803 or 1809 update), uninstalling the USB host controller, reinstalling it and only having a 50/50 shot of it recognizing the GPS. My work device, a Surface Laptop running Windows 10 Pro (still on 1803) recognizes it every time I plug it in (as does an old iMac).

    What can I do to fix this?
    #1
  2. Gadgetech

    Gadgetech Been here awhile Supporter

    Joined:
    Aug 6, 2017
    Oddometer:
    556
    Location:
    Cumming, GA
  3. VagrantStain

    VagrantStain n00b

    Joined:
    Apr 30, 2014
    Oddometer:
    6
    Location:
    Bayfield, CO
  4. Gadgetech

    Gadgetech Been here awhile Supporter

    Joined:
    Aug 6, 2017
    Oddometer:
    556
    Location:
    Cumming, GA
    The whole sentence in red is a link to the thread.
    #4
  5. VagrantStain

    VagrantStain n00b

    Joined:
    Apr 30, 2014
    Oddometer:
    6
    Location:
    Bayfield, CO
    Thx! My issue seems to be with my laptop USB ports. Probably a driver issue.
    #5
  6. Gadgetech

    Gadgetech Been here awhile Supporter

    Joined:
    Aug 6, 2017
    Oddometer:
    556
    Location:
    Cumming, GA
    I though that was my issue as well. It hasn’t resolved it 100% but I have more success connecting now.
    #6