Corrupt GPX ??

Discussion in 'GPS Tracks - Oz and Kiwi Land' started by cascade63, Mar 25, 2019.

  1. cascade63

    cascade63 Been here awhile

    Joined:
    Jul 19, 2009
    Oddometer:
    748
    Location:
    To the Left of Centre
    I've received the GPX Files from 4x4WA for Mundairing to Albany, 'The Track'

    Ok where Im at, techno phobic, got the gear but have FA idea !!

    Im using Basecamp and want to get the track to a route then onto my Zumo 590.

    When I download the GPX files into Basecamp this rubbish happens in two areas. Further up and here on this screen grab.

    Screen Shot 2019-03-23 at 4.12.32 PM.png

    Ive tried finding the corrupt points but no luck. Is there anywhere that teaches old idiots like me how to work this thing ?? Cant figure out how to make it right.

    Funnily enough though I just did it all on my Samsung S9+ opening the GPX file from my Gmail and putting it on OSMAND without one iota of issues like garmin is giving me !!!!
    #1
  2. sierra_victor

    sierra_victor Been here awhile

    Joined:
    Dec 14, 2008
    Oddometer:
    176
    Location:
    Matraville, NSW
    #2
  3. Rider 101

    Rider 101 Time poor

    Joined:
    Feb 8, 2012
    Oddometer:
    3,441
    Location:
    Avoiding the coal holes Upper Hunter NSW
    Might be a bit late. If you want to send me the gpx file I might be able to correct using Memory-Maps
    #3
  4. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    9,961
    Location:
    alabama
    upload the gpx here on adv and I'll fix it
    #4
  5. wbbnm

    wbbnm Long timer

    Joined:
    Dec 18, 2007
    Oddometer:
    5,724
    Location:
    MN and NM
    This does not look like a corrupt file. It looks like what is going on is that the track jumps from one area to another then follows the track in that area and then jumps back to where it was.

    You can find this in the track file by opening the track window and scrolling and watching the track cursor on the screen. If you have trouble seeing the scroll cursor, try scrolling while holding the shift key. This will highlight the range of points selected.

    One way to fix this would be to first cut out the track points in the deviation and then paste them back in at the end of the track data at Denmark. But you will still get an annoying jump from Denmark back up to the Mt. Lindst turnoff.

    You could fix this by just having a separate track for the Mt. Lindst segment. Or insert a track that goes backwards from Denmark up to the cutoff. You could create this track by creating a copy of what you have, inverting it, delete everything but the desired new segment and then paste that segment back in the original file at the right place.

    Or you could use the track draw tool to draw the new segment and then paste that back into your original.
    #5