Navigator vi launch problem

Discussion in 'Mapping & Navigation' started by mvk66, Sep 14, 2018.

  1. mvk66

    mvk66 2012 BMW GSA, 2018 GSA, 2016 KTM 690 Enduro

    Joined:
    Aug 6, 2012
    Oddometer:
    14
    Location:
    Fort Worth
    i just got the vi and it won’t boot up. I’m stuck on what looks like a charging screen for hours. Has anyone seen this? No mention or pic of this screen in the manual or from Garmin.. the battery in the pic has a question mark in it...

    I’m thinking the battery is bad right out of the box...

    Attached Files:

    #1
  2. JimVonBaden

    JimVonBaden "Cool" Aid! Supporter

    Joined:
    Feb 11, 2005
    Oddometer:
    79,030
    Location:
    Alexandria, VA
    It will stay like that until you unplug it from your computer. Put it on the bike and you will boot fine.
    #2
  3. mvk66

    mvk66 2012 BMW GSA, 2018 GSA, 2016 KTM 690 Enduro

    Joined:
    Aug 6, 2012
    Oddometer:
    14
    Location:
    Fort Worth
    It does the same thing on the bike. I just bought the bike (2018 GSA) 65FF1A25-71A7-4076-A53D-9D4C3CD6E1AC.jpeg last Saturday and got this in today... I guess if it was easy everyone would do it...
    #3
  4. JimVonBaden

    JimVonBaden "Cool" Aid! Supporter

    Joined:
    Feb 11, 2005
    Oddometer:
    79,030
    Location:
    Alexandria, VA
    Do a hard reset. Push the power button and hold it until it goes dark. Then install it.
    #4
  5. mvk66

    mvk66 2012 BMW GSA, 2018 GSA, 2016 KTM 690 Enduro

    Joined:
    Aug 6, 2012
    Oddometer:
    14
    Location:
    Fort Worth
    If I remove it from the cradle it goes dead like there is no power source and won’t do anything. I’ve pulled the battery out a couple of times thinking the connection was bad. My nav iv from my 2012 GSA boots up fine in the new cradle but doesn’t have the interface to operate with the tft screen.
    #5
  6. JimVonBaden

    JimVonBaden "Cool" Aid! Supporter

    Joined:
    Feb 11, 2005
    Oddometer:
    79,030
    Location:
    Alexandria, VA
    Can you swap batteries?
    #6
  7. mvk66

    mvk66 2012 BMW GSA, 2018 GSA, 2016 KTM 690 Enduro

    Joined:
    Aug 6, 2012
    Oddometer:
    14
    Location:
    Fort Worth
    Well third time’s a charm... I pulled the battery and found a small piece of lint keeping it from getting a full connection. Booted right up after that...
    #7
    RoundTrip, MrVvrroomm and scfrank like this.
  8. JimVonBaden

    JimVonBaden "Cool" Aid! Supporter

    Joined:
    Feb 11, 2005
    Oddometer:
    79,030
    Location:
    Alexandria, VA
    :thumb
    #8