Phone GPS Issue With Hotspot

Discussion in 'Mapping & Navigation' started by georgeXcore, Jul 21, 2020.

  1. georgeXcore

    georgeXcore Beeema 1200GS

    Joined:
    Jan 2, 2018
    Oddometer:
    55
    Location:
    Raleigh, NC
    Hey I just picked up a Kyrocera Duraforce Pro and got everything setup ready to go.

    My plan was to keep my iPhone in my pocket with the hotspot turned on and the Duraforce tethered to the wifi. That way I could run things like Spotify/Pandora through something I could still control while riding.

    With that I found that I can't connect to the wifi hotspot created by my iPhone XS. On the android side I keep getting an authentication error, the password is definitely correct. I tried some troubleshooting by resetting the phones, changing the hotspot login, etc. I found my laptops (both Mac and Linux) can connect to my iPhone, as well as my iPad and roku. So I think it's something with the android phone. Has anyone else run into this?

    I found that I can connect to my iPhone from the Duraforce via Bluetooth, and that provides an internet connection. However I'm not too sure if I want to run that through bluetooth, so I'm hoping the wifi hotspot can work out in the end.
    #1
  2. flamingm0e

    flamingm0e Long timer

    Joined:
    Feb 21, 2017
    Oddometer:
    1,562
    Location:
    Oklahoma
    I think the DFP requires 2.4ghz? I know that when I used my OnePlus 6 and my Samsung Galaxy S10+ I found issues with certain devices connecting to 5ghz. Can you change that on iPhone hotspot settings?
    #2
  3. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    10,005
    Location:
    alabama
    get screenshots of your iPhones hotspot settings
    #3
  4. georgeXcore

    georgeXcore Beeema 1200GS

    Joined:
    Jan 2, 2018
    Oddometer:
    55
    Location:
    Raleigh, NC
    I don't think there is much in terms of settings for the iPhone's hotspot. There is the enable personal hotspot in Settings>Cellular, then Allow Others to Join and password in the Settings>Personal HotSpot settings. Here is a screen shot of the Personal HotSpot settings, with the PW scribbled out. Like I said the bluetooth connection does allow internet but it seemed super slow though, so I'm hoping to get the wifi stuff working. If it doesn't get internet it's still a decent weather proof GPS that I picked up for $40.


    IMG_4407.jpg
    #4
  5. EmmEff

    EmmEff Long timer

    Joined:
    Oct 21, 2008
    Oddometer:
    2,300
    Location:
    Innisfil, Ontario, Canada
    Do you have your hotspot set as discoverable? On my iPhone X running iOS 13.6, swipe from the top right, long press the WiFi icon, and click on "Personal Hotspot". It will show as "Not Discoverable" by default. You will need to do this regardless of whether it's enabled as in the screenshot above.
    #5
  6. georgeXcore

    georgeXcore Beeema 1200GS

    Joined:
    Jan 2, 2018
    Oddometer:
    55
    Location:
    Raleigh, NC
    DAMN! That could be it, I'm away from the Android phone but that totally could be it. I have the Allow Others to Join enabled but when I long press the wifi toggle it is Not Discoverable. I'll check that later tonight and let you know if that works.
    #6
  7. georgeXcore

    georgeXcore Beeema 1200GS

    Joined:
    Jan 2, 2018
    Oddometer:
    55
    Location:
    Raleigh, NC
    Bah that didn’t help, but good suggestion though.
    #7
  8. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    10,005
    Location:
    alabama
    I tried sharing from my iPhone 6s+ to my dfpro and it worked fine.

    what version iOS are you running
    #8
  9. georgeXcore

    georgeXcore Beeema 1200GS

    Joined:
    Jan 2, 2018
    Oddometer:
    55
    Location:
    Raleigh, NC
    I'm running version 13.5.1 of iOS. The odd thing is I can see the blue connection thing start in the upper left corner of the iPhone show then quickly go away. That's when the android phone says authentication error, possibly bad password. The Android phone is set to use WPA2 and when I connect to the iPhone hotspot on my laptop it shows using WPA2 authentication. It's just plain weird. Bluetooth works for getting the Duraforce to use data while riding but man this wifi thing is weird.
    #9
  10. Jamie Z

    Jamie Z I'm serious. Supporter

    Joined:
    Oct 17, 2006
    Oddometer:
    10,609
    Location:
    Around Denver
    Hi George...

    I've connected my Duraforce Pro and Duraforce Pro 2 (as well as numerous other devices) to my iPhone 7 Plus hotspot without any issues, so I'm not sure how much I can offer.

    I did have a problem with the WiFi on my Duraforce Pro when I first got it. I found a setting in the menu called "Avoid Bad WiFi Connections."

    [​IMG]

    When I turned that to "OFF", that seemed to fix my problems with WiFi.

    Just throwing that out there.

    Jamie
    #10
  11. georgeXcore

    georgeXcore Beeema 1200GS

    Joined:
    Jan 2, 2018
    Oddometer:
    55
    Location:
    Raleigh, NC
    That must be a setting on the newer version of Android, the latest I can get is 7. Thanks for all of the suggestions
    #11
  12. Jamie Z

    Jamie Z I'm serious. Supporter

    Joined:
    Oct 17, 2006
    Oddometer:
    10,609
    Location:
    Around Denver
    Hmmm... thought that was with Android 7 on the Verizon Duraforce Pro. But it's been a few months. I don't remember exactly.
    #12
  13. flamingm0e

    flamingm0e Long timer

    Joined:
    Feb 21, 2017
    Oddometer:
    1,562
    Location:
    Oklahoma
    That is Android 7

    It is. 7 is the latest a Duraforce Pro can get.
    #13
  14. Jamie Z

    Jamie Z I'm serious. Supporter

    Joined:
    Oct 17, 2006
    Oddometer:
    10,609
    Location:
    Around Denver
    The screenshot I posted is from a Duraforce Pro with Android 7.
    #14