reserve light remaining on

Discussion in 'KTM 950/990' started by Crazygreek, Oct 6, 2019.

  1. Crazygreek

    Crazygreek Adventurer

    Joined:
    May 28, 2015
    Oddometer:
    60
    Location:
    Greece
    hi!after washing my bike the reserve light remaining on.is full of gasoline.I tried already by pushing the set button but nothing change.anyone whith the same issue?
    #1
  2. Boatman

    Boatman Membership has it's privileges ;-) Supporter

    Joined:
    Mar 9, 2005
    Oddometer:
    13,891
    Location:
    Mill Spring, NC
    Bike?
    #2
  3. Crazygreek

    Crazygreek Adventurer

    Joined:
    May 28, 2015
    Oddometer:
    60
    Location:
    Greece
    ktm adventure 990R 2010
    #3
  4. tomdubz

    tomdubz getting there Supporter

    Joined:
    Jun 29, 2010
    Oddometer:
    1,206
    Location:
    4 Cornerstan
    You're pushing the set button while in the "F" trip mode right? My sensor failed a while back and the light stayed on permanently. Replacing the sensor made the light go away and work only when it should. When I replaced the sensor I noticed the wiring into it was compromised. Looked like I sanded it down somehow. Did you get too wild with the power washer up the skirt?

    '09 990 90K miles
    #4
  5. Crazygreek

    Crazygreek Adventurer

    Joined:
    May 28, 2015
    Oddometer:
    60
    Location:
    Greece
    yes Tom I push the set button at the F mode and nothing.probably I need also a new sensor.now F they weight 989.6 km so I fill up the tanks almost 5 times and the reserve lamo still on.I don t think so that I make it too wild with the power washer.
    #5
  6. Mud Bucket

    Mud Bucket Been here awhile

    Joined:
    Aug 9, 2007
    Oddometer:
    194
    Location:
    North Vancouver,B.C, Can
    I have a 2010 990R and the sensor just stopped working this year while in Baja. Sucks not having the light pop on so I'm reminded to open the fuel from the rear reserve tank. I'm going to check the wires and maybe I need to replace it.
    #6
  7. Crazygreek

    Crazygreek Adventurer

    Joined:
    May 28, 2015
    Oddometer:
    60
    Location:
    Greece
    thanks mud bucket!that the way that I asked,to buy new one and replace or to check the cables first.:cromag
    #7
  8. Zuber

    Zuber Zoob Supporter

    Joined:
    Sep 28, 2004
    Oddometer:
    5,418
    Location:
    West of the West, Oregon
    Reach under the tank and un-do the wire to the sensor? Now what do you have?
    Still on - wet dash.
    Went off - bad sensor.
    #8
  9. Crazygreek

    Crazygreek Adventurer

    Joined:
    May 28, 2015
    Oddometer:
    60
    Location:
    Greece
    Zuber yesterday I took off the tank and I disengage the contacts of the sensor.The reserve light become off,today after 200 kms became on again and after filling the tanks full off gasoline is still on(F write now 265).Finally I order a new sensor and after tommorow I replaced it.
    #9
  10. Crazygreek

    Crazygreek Adventurer

    Joined:
    May 28, 2015
    Oddometer:
    60
    Location:
    Greece
    problem solved with a new sensor and 60$,but I realized that the old sensor they don't have serious problem only scratched insulation to the wires 20191011_194028.jpg
    #10
    mountaincadre likes this.