Yamaha WR250R Mega Thread

Discussion in 'Thumpers' started by Sock Monkey, Apr 7, 2008.

  1. WileyRTW

    WileyRTW Wiley

    Joined:
    Jun 17, 2009
    Oddometer:
    439
    Location:
    San Diego, Ca
    Yeah I haven't paid attention to how long it sat, and tried starting it with the old gas. When it didn't start, knowing it was old gas I drained the tank, saw all the crud, and replaced the filter for good measure. I will give everything a good cleaning after I give cleaning the injector a try. I have the air filter out until I get it running, and have tried WOT as well, to no avail.

    I am pretty new to diagnosing problems....if it starts briefly with starter fluid that would not rule out an electrical problem since I am just bypassing everything correct? Still going to focus on if it is getting fuel, but will need to watch some videos on how to test wires.

    A few months ago I had rode it with too much oil in the bike. I was in Baja and wanted to make sure I got back. It started stalling around the border, keeping the engine revved would keep it running. When I got home I found the oil had worked its way into the air box. It was drained and cleaned, and while not recommended it doesn't seem to be a terrible thing to do but an FYI in case its related. The bike then sat because I lost some bolts to the clutch holder and rather than go to home depot I ignored it. So new battery, fuel pump, disconnected all electrical accessories, bike runs for a few seconds with starter fluid, so running out of ideas.

    I could be over analyzing, but there may be a small thumping of air from the exhaust when trying to start, like a bass drum. Valves were adjusted months ago, maybe even 2 years ago....do not think it is related.
  2. BMW-K

    BMW-K F800GS FTW!

    Joined:
    Nov 11, 2004
    Oddometer:
    2,791
    Location:
    Anaheim, CA
    FWIW, the Yamaha injectors I tested sprayed in a "Y" pattern, not an actual clouded mist. Kind of a misted Y.

    In my case it did turn out to be the fuel pressure regulator. Getting to that point I'd shotgunned the plug, injector and fuel pump as well as flushed the fuel twice.

    The test that led me to the pressure regulator was spraying a bit of Starter Fluid into the airbag. Bike started instantly and ran on the starter fluid. So the logical chase was the bike not getting enough fuel to the injectors in the end. That was either the pump or something. Thankfully someone on the board suggested the regulator and that was the answer.

    Good luck!
  3. Yinzer Moto

    Yinzer Moto aka: trailer Rails Supporter

    Joined:
    Jun 13, 2008
    Oddometer:
    29,075
    Location:
    Pittsburgh PA

    I don’t remember if it was mentioned, toss a spark plug in it. This bike can be sensitive to that.
  4. WileyRTW

    WileyRTW Wiley

    Joined:
    Jun 17, 2009
    Oddometer:
    439
    Location:
    San Diego, Ca
    I did not mention, but I did put a new one in when I tested for spark. Appreciate it
    Yinzer Moto likes this.
  5. AUstate

    AUstate Adventurer

    Joined:
    Jul 3, 2014
    Oddometer:
    77
    Location:
    Los Angeles, CA
    Hey Wiley, just saw your post. Along with checking out your fuel pump, the screen and the fuel pressure regulator, I would for sure take out your injector and clean it as well.

    The injector is very easy to remove and clean, and at first I would just try and spray out the tiny little screen on the injector before trying to cycle it like the video.
    Here is a small write up from when i removed my injector after my regulator failed and must of sent small particles to the injector screen clogging it. After just blowing it off with brake clean, it has been running perfect now.

    -----quoted----

    "I also would maybe reccomend people to take out the injector and check the screen. I think alot of people would be surpised what they see, and may gain some extra power or a slight bog may just go away.
    Also I flushed the "Rail" as well with a little break cleaner, not much I dont know whats inside that pulse dampener on the end. Didnt want to make IT mad. But more of that reddish colored stuff came out of the metal rail.


    Not sure what that is, rust, dirt... I did ride that bike in Oklahoma once. That Red Oklahoma soil is powerful stuff...


    Removing the injector is very simple. Remove tank, next step is to super clean everything around the injector. Get it spotless, then take off the fuel injector eletrical plug connection and clean some more.
    Blow everything dry, and the injector rail/housing is 2 really tight phillips screws hoilding it to the throttle body. Be careful with those. Once screws are out, (a stick magnet is handy there) lift straight off the injector.

    The rail will either come off the injector or the injector will come out of the throttle body. On the bottom of the Injector is 1 rubber gasket/seal. On top is the same type, followed by a small oring on the top tip.

    Gently take off all rubber before using brake cleaner. Dont mess with bottom of the injector. And dont put any tool inside the top screen. Be gentle."
  6. JNS Engineering

    JNS Engineering Been here awhile

    Joined:
    Jan 1, 2010
    Oddometer:
    515
    Location:
    Oregon
    Limited quantity now available for discounted pre-order on the JNS Engineering website. I expect to start shipping mid December. :beer

  7. AUstate

    AUstate Adventurer

    Joined:
    Jul 3, 2014
    Oddometer:
    77
    Location:
    Los Angeles, CA
    Very cool, I might have missed if you posted info earlier, I really want to upgrade my light situation,is this quite a substantial upgrade over stock? Any comparison pics?

    Love the simplicity, Im really interested, but also thinking about finding 2 aux lights to add somewhere as well
  8. WileyRTW

    WileyRTW Wiley

    Joined:
    Jun 17, 2009
    Oddometer:
    439
    Location:
    San Diego, Ca
    Ok, thanks guys. So I ran the injector diagnostic and could hear it click 5 times, I filled a tube with carb cleaner but when it clicks nothing sprays out at all... I assume I should replace the injector, and have most likely found the issue, or does it not spray during the diagnostic?

    If this seems to be the problem, anyone have a part number?
  9. Border411

    Border411 Been here awhile

    Joined:
    Sep 24, 2017
    Oddometer:
    375
    Location:
    Northern Virginia
    Did you do that with pressure on the "upstream" side of the injector? If not....there wasnt any force to MAKE it spray out, so that would be a false test.
  10. Yinzer Moto

    Yinzer Moto aka: trailer Rails Supporter

    Joined:
    Jun 13, 2008
    Oddometer:
    29,075
    Location:
    Pittsburgh PA
    When you replaced the fuel pump, did you replace the fuel pressure regulator?
  11. WileyRTW

    WileyRTW Wiley

    Joined:
    Jun 17, 2009
    Oddometer:
    439
    Location:
    San Diego, Ca
    Just gravity/ and pressure from the ...the spray can same setup as guy in vid, but spraying into the rail. Do I need to use an external battery with wires straight to injector... I was hoping that's what happened in the diagnostic.

    Only the pump. Is that the damper thing...I will investigate not sure what/where this is
  12. Yinzer Moto

    Yinzer Moto aka: trailer Rails Supporter

    Joined:
    Jun 13, 2008
    Oddometer:
    29,075
    Location:
    Pittsburgh PA
    It is on the top of the fuel pump housing.

    B20657B9-669A-45F4-B181-A95C3AF5612E.jpeg
    WileyRTW likes this.
  13. WileyRTW

    WileyRTW Wiley

    Joined:
    Jun 17, 2009
    Oddometer:
    439
    Location:
    San Diego, Ca
    Ah yes that thing was what I was calling damper thingy based on other internet noobs...thank you. I should replace that based on looks alone.

    I believe I'm getting fuel from the tank to the rail as I unplugged the hose and cycled the pump, which resulted in gas coming out. I have spark, and air box is empty, so I feel like it's that injector.
    Yinzer Moto likes this.
  14. Yinzer Moto

    Yinzer Moto aka: trailer Rails Supporter

    Joined:
    Jun 13, 2008
    Oddometer:
    29,075
    Location:
    Pittsburgh PA
    I am not saying it is not the injector but I think the pressure regulator is inexpensive and easy to replace if you have the tank drained. I try to keep track of issues the WR has and what people have had to replace, the pressure regulator is something that goes bad every now and again.

    https://www.highflowfuel.com/i-3546...wr25r-2008-2020-replaces-3d7-13907-10-00.html
    HardWorkingDog likes this.
  15. WileyRTW

    WileyRTW Wiley

    Joined:
    Jun 17, 2009
    Oddometer:
    439
    Location:
    San Diego, Ca
    Gotta hand it to those Yamaha engineers:rofl
    ACR, woofer2609, PlowHand and 2 others like this.
  16. WileyRTW

    WileyRTW Wiley

    Joined:
    Jun 17, 2009
    Oddometer:
    439
    Location:
    San Diego, Ca
    Oh yeah I agree, and I am hopeful it is the injector meaning I may have solved the issue instead of the not knowing nonsense, but I am open to all possibilities. Plus as said it looks terrible I would be surprised if it is working properly...now that I know the proper name I will replace it. Going to build up a DIY setup to try and get more pressure through the injector for cleaning, while it is hooked to a battery so I can leave it open a few seconds.....see if I can get anything coming out.

    If I need a new injector I am not seeing many options online, should I go straight to a dealer?
  17. Yinzer Moto

    Yinzer Moto aka: trailer Rails Supporter

    Joined:
    Jun 13, 2008
    Oddometer:
    29,075
    Location:
    Pittsburgh PA
    I would be inclined to buy an OEM injector but someone else may know of another option. I have no experience with having to source one.
  18. BMW-K

    BMW-K F800GS FTW!

    Joined:
    Nov 11, 2004
    Oddometer:
    2,791
    Location:
    Anaheim, CA
    Wiley, the WR injector is shared by many models. I bought a "3-pack" of injectors from a totaled MT09 for $21 off Ebay.
    Bitingdog and ACR like this.
  19. facablade

    facablade Been here awhile

    Joined:
    May 30, 2016
    Oddometer:
    211
    Location:
    SPAIN
    Hi it's time to engine oil change.
    I want to chain filter too so following the manual 1.4 litres is the oil quantity needed but which is the use of 1.5 total amount?
    IMG_20191114_185837.jpg
  20. Yinzer Moto

    Yinzer Moto aka: trailer Rails Supporter

    Joined:
    Jun 13, 2008
    Oddometer:
    29,075
    Location:
    Pittsburgh PA
    A full motor rebuild uses 1.5.
    Ginger Beard and rsteiger like this.