Yes or No, Have you had a fuel pump problem on your 990.

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by Gimme 2, May 7, 2009.

  1. Juan Loboe

    Juan Loboe Been here awhile

    Joined:
    Jan 1, 2008
    Oddometer:
    599
    Location:
    Central AZ Megatropolis
    About 8,400 miles and no problems.
    #41
  2. dogsbody

    dogsbody Occasionally lucid

    Joined:
    Aug 2, 2006
    Oddometer:
    304
    Location:
    Adelaide Hills-South Oz
    Changed pump intake filter set at 28,000kms after experiencing surging under hard throttle.
    Filter was dirty and tank had particulates in it. Rinsed tank out, fitted new filter and no problems since. :D
    Filter was quite expensive. If I'd had access to an ultrasonic bath for cleaning it I think I could have reused the filter with no issues.
    #42
  3. crashmaster

    crashmaster ow, my balls!

    Joined:
    Mar 9, 2007
    Oddometer:
    5,564
    Location:
    Alaska
    This is an interesting, and slightly disturbing thread.

    I have about 10K on my 07 with no pump issues yet.

    However, in light of this thread, it looks like I'm going to start carrying a spare pump and filters with me when I take off solo into the MOFN.
    #43
  4. viola-tor

    viola-tor Needs to ride!

    Joined:
    Feb 27, 2008
    Oddometer:
    2,071
    Location:
    Rockies. Freakin' Rockies.
    '07 Adv., 15K miles, no probs, but now I'm wondering if I should order a kit...

    Anybody have the recommended parts list for a roadside rebuild handy? Might be a good thing to have on this thread if a lot of ppl will be reading it.
    #44
  5. crashmaster

    crashmaster ow, my balls!

    Joined:
    Mar 9, 2007
    Oddometer:
    5,564
    Location:
    Alaska
    #45
  6. Agave

    Agave El Corazón

    Joined:
    Aug 5, 2007
    Oddometer:
    167
    Location:
    Portland,OR
    As I never ride this bike anywhere close to home, this issue is always in the back of my mind and freaks me out a little!07 990 ADV. 10K on the bike, no problems, lots of shady fuel. Fingers crossed
    #46
  7. tahoeacr

    tahoeacr Long timer

    Joined:
    Jan 7, 2007
    Oddometer:
    2,256
    Location:
    Lake Tahoe
    Sorry, just a little humor. Never had a problem and I run the tank to reserve all the time. However, I only put chevron premium in it.
    #47
  8. Gimme 2

    Gimme 2 wheels , with nobs

    Joined:
    Mar 29, 2009
    Oddometer:
    2,801
    Location:
    still looking
    wtf's an ultrasonic bath, an icecream container and turps? i think a profilter prefilter is sounding all the better.:wink:
    #48
  9. Vicks

    Vicks gets stuck in sand

    Joined:
    Oct 4, 2006
    Oddometer:
    3,393
    Location:
    gone RTW...
    +1 on the prefilter idea.

    I had this thought in the noon.... Would it help if we install some kind of a prefilter to the fuel pump assembly similar to the UNI prefilters for the Air box snorkel ? would there by a filter available for this kind of application ?
    #49
  10. dogsbody

    dogsbody Occasionally lucid

    Joined:
    Aug 2, 2006
    Oddometer:
    304
    Location:
    Adelaide Hills-South Oz
    http://www.soniclean.com.au/ulc/faq.html

    A few hours in one of these and the "pillow" filter looks like new. But I'd probably replace the pleated element filter rather than clean it. Just to be sure.

    Pity they only come as a kit, not individually.........:bluduh
    #50
  11. Bonkers the Dog

    Bonkers the Dog Ned Catcher

    Joined:
    May 19, 2006
    Oddometer:
    211
    Location:
    S-West Coast Scotland
    Yes, got it back from the dealer a few days ago.

    £480 for a new pump fitted! On top of a £450 service bill

    FUCK!

    A grand....you would think I drove a Porsche.

    Not pleased.

    Actually thinking of selling the bastard as it has had too many problems.
    #51
  12. skier

    skier genius or insanity?

    Joined:
    Jun 6, 2007
    Oddometer:
    270
    Location:
    Durango/Silverton, Colorado
    11,000 miles on an 07 990, not yet 2 years, no fuel problems
    #52
  13. flyingbeard

    flyingbeard Long timer

    Joined:
    Apr 29, 2006
    Oddometer:
    1,135
    Location:
    Ann Arbor, MI
    13980 MI (22500 KM) on a 07 990 Adv and no problems at all after first FI re-mapping. Just oil changes and tires:evil . Hard on the throttle all the time and run into reserve (20-30 miles) with high test gas.
    #53
  14. azkiwi

    azkiwi message in a bottle

    Joined:
    Aug 11, 2004
    Oddometer:
    10,471
    Location:
    Upstate AZ
    Shoulda made it a poll ... I tally 8 problems in 35 reports


    #54
  15. duct tape

    duct tape Lost

    Joined:
    Jul 9, 2007
    Oddometer:
    566
    Location:
    Colorful Colorado
    And there seems to be a distinct lack of '08's and '09's (maybe too early for these) among the 8....?
    #55
  16. Adam990

    Adam990 Adventurer

    Joined:
    Mar 12, 2009
    Oddometer:
    35
    Location:
    Edmonton, Alberta
    I've got almost 2000 km on my 09 990 Adventure and no problems yet, runs like a dream !
    #56
  17. unlokr

    unlokr Been here awhile

    Joined:
    Dec 19, 2007
    Oddometer:
    139
    07 990 w/ 18,500 and not a single problem anywhere.
    #57
  18. Rideimal

    Rideimal Been here awhile

    Joined:
    Apr 22, 2008
    Oddometer:
    104
    Location:
    Surrounded by Texas
    '08 990, 4500 miles, no problems
    #58
  19. danceswithdeer

    danceswithdeer Space Wrangler

    Joined:
    Mar 19, 2008
    Oddometer:
    176
    Location:
    Wyoming
    1400 miles...just got it back from the shop. Intermittent fuel pump. The thing is amazing now. I think the pump was weak from the get/go as the bike seemed kind of anemic in headwinds and passes, etc. I rode home through the Black Hills from Rapid City, and did a stretch between Necastle and Moorcroft (about 47miles) at a steady indicated 110mph all the way with lots of throttle left. Bike is way more fun now.

    With the old fp, it felt wheezy at anything over 100 and would begin to cut-out and stall after about 50-80 miles. Again, most of the time, if I'd shut it off for five minutes or so, it would go another 50-80 miles. It also had a rougher idle with the old fuel pump.

    And the fuel pump did not test bad. I took it over to the shop in Rapid and left it for a week; the tech said he did all the diagnostics, etc. but could not find a problem; he took it out for a ride and felt that it was fine. So I went back over and took it out for a 50 mile ride, and just like clockwork, it started acting up; I stayed close by the shop and went right back over, left it idling, and got the tech. He jumped on the bike, and it did its thing, bogged, popped, and lost power...then it stalled in traffic (like it's done to me - scary)...he came back wide-eyed and a believer, and put a new fuel pump in...and it's perfect now.

    I'd be interested to know what's failing.
    #59
  20. Quietus

    Quietus Mariner

    Joined:
    Oct 7, 2007
    Oddometer:
    581
    Location:
    N.Smirni - Athens - Greece
    '07 990 bought 11 months ago. 28000kms no problem till know!!
    #60